SilverCloud Disabling TLS 1.0

We have detected that your browser is using an unsupported version of TLS. Read the information below to find out what you need to do to continue using SilverCloud securely.

Congratualtions! We have detected that your browser is using a supported version of TLS so the information below may not be of relevance to you.

What is TLS?

TLS (Transport Layer Security) enables secure web browsing and other forms of secure communication. It uses encryption to prevent the transmitted data from being tampered with or intercepted. TLS is used to secure communications for web browsers, VPNs, and database servers.

The TLS 1.0 encryption protocol is no longer considered secure. SilverCloud must disable it in order to maintain a high standard of security for our users, and will require a browser that supports TLS 1.1 or TLS 1.2.

TLS 1.0 will be disabled from 6 June 2017

Starting in May 2017, SilverCloud will start to disable the TLS 1.0 encryption protocol for all connections to the platform. This means that connections must take place over TLS 1.1 or TLS 1.2.

You will experience issues connecting to SilverCloud via your browser if it is not supported, or if you have not enabled the supported encryption protocols. You can check the support of your preferred web browser for TLS 1.1 and TLS 1.2 at caniuse.com.

The secure protocols are very widely supported in current versions of web browsers such as Microsoft Edge, Microsoft Internet Explorer 11, Mozilla Firefox, Google Chrome, Apple Safari.

However, some older browsers may require a configuration change, or may not support secure protocols.

Timeline

2 May 2017
Before logging in, an alert will be made to anyone connecting with an unsupported browsers that SilverCloud will be disabling TLS 1.0.
29 May 2017
Before logging in, an urgent alert will be presented to anyone connecting with an unsupported browser.
6 June 2017
Official end date. Anyone trying to access SilverCloud on an unsupported browser will be denied access to the site.

Unsupported Browsers

Microsoft Internet Explorer (IE) 8, 9, 10 and older

These browser versions are not supported by Microsoft and you should upgrade to IE 11, or use an alternative supported browser.

Enable TLS 1.1 and TLS 1.2 in IE 9 or 10

You can use the following steps to make IE 9 or 10 compatible with TLS 1.1 and TLS 1.2:

  1. Go to Tools and select Internet Options
  2. Select the Advanced tab in Internet Options
  3. Enable TLS 1.1 and TLS 1.2. You can also disable SSl 3.0 and TLS 1.0 for added security, but this may affect your ability to connect to other sites.
  4. Click OK

Android OS Web Browser 4.4 and older

Some versions of Android Browser 4.4 and 4.4.x may support TLS 1.1 and TLS 1.2, depending on the manufacturer.

Earlier versions of Android Browser do not support TLS 1.1 or TLS 1.2.

Recommendation: update your Android OS version if possible and try Google Chrome or an alternative browser.